Mondriaan's Dream POJ - 2411 (状压dp,轮廓线dp)

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

这里写图片描述
Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output

1
0
1
2
3
5
144
51205

大致题意:让你用1*2规格的小矩形去覆盖n*m的矩阵,不能重叠,问有多少种方案恰好铺满

思路:对于当前行的某一列,如果我们竖着铺,那么会对下一行造成影响,如果横着铺,则不会。我们用二进制表示当前一行所铺格子的状态,然后预处理出从当前行的状态state1所能够转移到的下一行的状态state2。最后遍历每一行,进行简单的状压dp即可。

代码如下

#include <cstdio>  
#include <cstring>  
#include <algorithm> 
#include <iostream> 
#include <vector>
using namespace std;  
#define ll long long   
int n,m;

ll dp[15][(1<<15)];
vector<int> Nex[(1<<15)];

void dfs(int j,int state,int nex)//准备放第j列,判断从当前行状态state所能能变换到的下一行的状态nex 
{
    if(j==m)//填完了m列 
    {
        Nex[state].push_back(nex);
        return;
    }
    if((1<<j)&state) dfs(j+1,state,nex);//不能填 
    else
    {
        //竖着
        dfs(j+1,state,nex|(1<<j));
        //判断能不能横着 
        if(j+1<m&&(1<<(j+1)&state)==0)
        dfs(j+2,state,nex); 
    }
}
int main ()  
{    
    while(scanf("%d%d",&n,&m)&&(n+m))
    {   

        memset(dp,0,sizeof(dp));
        for(int i=0;i<(1<<m);i++)
        Nex[i].clear();

        for(int state=0;state<(1<<m);state++)//枚举当前行的所有状态
        dfs(0,state,0);

        dp[0][0]=1;
        for(int i=0;i<n;i++)//枚举第i行 
        {
            for(int state=0;state<(1<<m);state++) //枚举第i行放置的情况 
            {
                if(dp[i][state])//如果第i行的状态state可达
                {
                    int len=Nex[state].size();
                    for(int j=0;j<len;j++)//枚举当前状态可以转移到的下一个状态
                    {
                            int nex=Nex[state][j];
                            dp[i+1][nex]+=dp[i][state];
                    }   
                }   
            }
        }

        printf("%lld\n",dp[n][0]);
    }   
    return 0;  
}  
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值