hdu 4081 Qin Shi Huang's National Road System

题目:http://acm.hdu.edu.cn/showproblem.php?pid=4081

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4716    Accepted Submission(s): 1616


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
  
  
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
  
  
65.00 70.00
 
题意:找一棵最小或者次小生成树,使其中一条边连接的P / 其他边的和 的权值最大。
思路:典型的次小生成树,先用kruskal搞出最小生成树的权值,然后用dfs+dp建有根树搞出树上任意两点间最长边,最后枚举边出答案。
之前一篇文章有写如何求解次小生成树: 次小生成树
这道题思路一直很清晰但是代码很搓一直wa。。。后来重敲了一次就过了
AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int M = 1010;
struct Point{
    double x, y, p;
    int id;
}point[M];
struct Edge{
    double p, dist;
    int a, b;
    bool operator < (const Edge &i) const {
        return dist < i.dist;
    }
}edge[M * M];
int nedge, fa[M];
int findfa(int a){
    if(fa[a] == a) return a;
    return fa[a] = findfa(fa[a]);
}
void unit(int a, int b) {
    int t1 = findfa(a), t2 = findfa(b);
    fa[t1] = min(t1, t2);
    fa[t2] = min(t1, t2);
}
double getDist(Point a, Point b) {
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}
void swap(int &a, int &b) {
    int t = a;
    a = b;
    b = t;
}
double maxedge[M][M];
double Kruskal() {
    double ret = 0.0;
    sort(edge, edge + nedge);
    for(int i = 0; i < nedge; i++) {
        int a = edge[i].a, b = edge[i].b;
        if(findfa(a) == findfa(b)) continue;
        ret += edge[i].dist;
        unit(a, b);
        maxedge[a][b] = maxedge[b][a] = edge[i].dist;
    }
    return ret;
}
int ver[M], cnt = 0;
bool vis[M];
void dfs(int now, int father, int n) {
    for(int i = 0; i < cnt; i++) maxedge[now][ver[i]] = maxedge[ver[i]][now] = max(maxedge[now][father], maxedge[father][ver[i]]);
    vis[now] = true;
    ver[cnt++] = now;
    for(int i = 0; i < n; i++) {
        if(vis[i] == false && maxedge[i][now] != 0)
            dfs(i, now, n);
    }
}
void init() {
    memset(maxedge, 0, sizeof maxedge);
    memset(vis, false, sizeof vis);
    memset(ver, 0, sizeof ver);
    cnt = nedge = 0;
    for(int i = 0; i < M; i++) fa[i] = i;
}
main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        init();
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++) {
            scanf("%lf %lf %lf", &point[i].x, &point[i].y, &point[i].p);
        }
        for(int i = 0; i < n; i++)
            for(int j = i + 1; j < n; j++) {
                edge[nedge].a = i, edge[nedge].b = j;
                edge[nedge].dist = getDist(point[i], point[j]);
                edge[nedge++].p = point[i].p + point[j].p;
            }
        double sum = Kruskal();
        dfs(0, 0, n);
        double ans = 0.0;
        for(int i = 0; i < nedge; i++){
                int a = edge[i].a, b = edge[i].b;
         //       printf("%d %d %f %f %f\n", a, b, edge[i].p, sum, maxedge[a][b]);
                ans = max(ans, edge[i].p / (sum - maxedge[a][b]));
            }
        printf("%.2f\n", ans);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值