Qin Shi Huang's National Road System HDU - 4081

Qin Shi Huang’s National Road System (HDU - 4081)

次小生成树的思想

题目描述
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself “Qin Shi Huang” because “Shi Huang” means “the first emperor” in Chinese.
在这里插入图片描述
Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people’s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
输入
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
输出
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
样例输入
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
样例输出
65.00
70.00
题意:
给出N个点的坐标以及每个点的人口, 要求将这N个点通过N-1条边连接起来, 权值为两点直接距离, B为距离和, 同时可以选中一条边, 使得该边权值变为0, A为该边两点人口数量. 求A/B的最大值(即B为n-2条边的权值和)
题解:
既然要求A/B的最大值, 就一定要A最大, B最小, 所以B需要求一下MST, A的话我们直接枚举每条边就好了, 如果该边已经在MST中, ans = max(ans, A/(MST-mp[i][j])); 否则ans = max(ans, A/(MST-max_dis[i][j]));

可以看到, 虽然这里没有直接使用次小生成树, 但是完全用到了次小生成树求出的几个数组, 这也是前面为何没有直接求出次小生成树的原因。

#pragma GCC optimize(3,"Ofast","inline")  	//G++
#include<bits/stdc++.h>

#define TEST freopen("C:\\Users\\hp\\Desktop\\ACM\\in.txt","r",stdin);
#define mem(a,x) memset(a,x,sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

using namespace std;
typedef long long ll;

const int inf=0x3f3f3f3f;
const ll INF=0x7fffffffffffffff;
const int mod=1e9+7;
const int maxn = 5e5+5;

int n,m,cnt;
struct node
{
    int x,y;
    double val;
    bool friend operator < (const node a,const node b)
    {
        return a.val<b.val;
    }
} a[maxn];
pair<int,int>b[maxn];
int val[maxn];
int re[maxn],vis[1005][1005];
double mp[1005][1005],max_dis[1005][1005];
vector<int>G[1005];
void init()
{
    mem(vis,0);
    for(int i=1; i<=n; i++)
    {
        re[i]=i;
        G[i].clear();
        G[i].push_back(i);
    }
}
int fin(int x)
{
    return re[x]==x?x:re[x]=fin(re[x]);
}
double getDis(int x1, int y1, int x2, int y2)
{
    return sqrt((double)(x1 - x2)*(x1 - x2) + (y1 - y2)*(y1 - y2));
}
double solve()
{
    double sum=0;
    init();
    for(int i=1; i<=cnt; i++)
    {
        int xx=fin(a[i].x),yy=fin(a[i].y);
        if(xx!=yy)
        {
            vis[a[i].y][a[i].x]=vis[a[i].x][a[i].y]=1;
            for(auto u:G[xx])
            {
                for(auto v:G[yy])
                {
                    max_dis[u][v]=max_dis[v][u]=a[i].val;
                }
            }
            sum+=a[i].val;
            re[xx]=yy;
            G[yy].insert(G[yy].end(),G[xx].begin(),G[xx].end());
        }
    }
    return sum;
}
int main()
{
//    ios;
    int T;
    cin>>T;
    while(T--)
    {
        cnt=0;
        cin>>n;
        for(int i=1; i<=n; i++)
        {
            int x,y;
            cin>>x>>y>>val[i];
            b[i]=make_pair(x,y);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                a[++cnt]=node{i,j,getDis(b[i].first,b[i].second,b[j].first,b[j].second)};
                mp[i][j]=mp[j][i]=getDis(b[i].first,b[i].second,b[j].first,b[j].second);
            }
        }
        sort(a+1,a+cnt+1);
        double MST=solve();
        double ans=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                int A=val[i]+val[j];
                if(vis[i][j]){
                    ans=max(ans,A*1.0/(MST-mp[i][j]));
                }
                else{
                    ans=max(ans,A*1.0/(MST-max_dis[i][j]));  //加入i-j边,形成次小生成树MST-max_dis[i][j]+mp[i][j],减去mp[i][j]即为所得
                }
            }
        }
        printf("%.2f\n",ans);
//        cout<<fixed<<setprecision(2)<<ans;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值