hdu6186 CS Course

http://www.elijahqi.win/archives/1473
Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers
a
1
,
a
2
,⋯,
a
n
, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except
a
p
.

Input
There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤
10
5

Then n non-negative integers
a
1
,
a
2
,⋯,
a
n
follows in a line,
0≤
a
i

10
9
for each i in range[1,n].

After that there are q positive integers
p
1
,
p
2
,⋯,
p
q
in q lines,
1≤
p
i
≤n
for each i in range[1,q].

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except
a
p
in a line.

Sample Input
3 3
1 1 1
1
2
3

Sample Output
1 1 0
1 1 0
1 1 0

搞一波前缀和后缀和就很好想 但是 注意边界..wa了无数发 要是这是后天的acm恐怕早就罚时t飞了

ans1的初始值需要给最大才行

#include <cstdio>
#define N 110000
inline int read(){
    int x=0;char ch=getchar();
    while (ch<'0'||ch>'9') ch=getchar();
    while (ch<='9'&&ch>='0'){x=x*10+ch-'0';ch=getchar();}
    return x;
}
int n,p,s1[N],s2[N],s3[N],a[N],ss1[N],ss2[N],ss3[N];
int main(){
    freopen("hdu6186.in","r",stdin);
    while (~scanf("%d%d",&n,&p)){
        for (int i=1;i<=n;++i) a[i]=read();s1[1]=a[1];ss1[n]=a[n];s2[1]=a[1];ss2[n]=a[n];s3[1]=a[1];ss3[n]=a[n];
        for (int i=2;i<=n;++i) s1[i]=s1[i-1]&a[i];
        for (int i=2;i<=n;++i) ss1[n-i+1]=ss1[n-i+2]&a[n-i+1];
        for (int i=2;i<=n;++i) s2[i]=s2[i-1]|a[i];
        for (int i=2;i<=n;++i) ss2[n-i+1]=ss2[n-i+2]|a[n-i+1];
        for (int i=2;i<=n;++i) s3[i]=s3[i-1]^a[i];
        for (int i=2;i<=n;++i) ss3[n-i+1]=ss3[n-i+2]^a[n-i+1];
        for (int i=1;i<=p;++i) {
            int ans1=0x7fffffff,ans2=0,ans3=0;
            int pos=read();if (pos-1>=1){
                ans1&=s1[pos-1];ans2|=s2[pos-1];ans3^=s3[pos-1];
            }
            if (pos+1<=n){
                ans1&=ss1[pos+1];ans2|=ss2[pos+1];ans3^=ss3[pos+1];
            }
            printf("%d %d %d\n",ans1,ans2,ans3);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值