hdu5025 Saving Tang Monk BFS

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2360    Accepted Submission(s): 848


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts. 

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M). 

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8



广搜,主要是标记怎么打。

用一个bool vis[105][105][15][40]; //<x, y, key, snake>

表示经过点(x, y)并且这时候收集了最大的key,并且将蛇杀死了哪几条

将每条蛇编上号,snake可以用二进制表示,利用1左移多少位来表示第几条蛇


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <cstdlib>

using namespace std;

struct node {
	int x, y;
	int t, key, snake;
	node(int x, int y, int t, int key, int snake) : x(x), y(y), t(t), key(key), snake(snake) {}
	node() {}
};

const int INF = 0x7fffffff;

int n, m, sx, sy;
int dir[4][2] = { { 0, 1 }, { 1, 0 }, { 0, -1 }, { -1, 0 } };
char mapp[105][105];
bool vis[105][105][15][40]; //<x, y, key, snake>

bool check(int x, int y) {
	if (x < 0 || x >= n || y < 0 || y >= n || mapp[x][y] == '#')
		return false;
	return true;
}

void bfs() {
	queue<node> Q;
	memset(vis, false, sizeof(vis));
	Q.push(node(sx, sy, 0, 0, 0));
	vis[sx][sy][0][0] = true;
	int ans = INF;
	while (!Q.empty()) {
		node tn = Q.front(); Q.pop();
		if (mapp[tn.x][tn.y] == 'T' && tn.key == m) ans = min(ans, tn.t);
		for (int i = 0; i < 4; i++) {
			int nx, ny, t, key, snake;
			nx = tn.x + dir[i][0], ny = tn.y + dir[i][1];
			t = tn.t; snake = tn.snake; key = tn.key;
			if (check(nx, ny)) {
				if ('A' <= mapp[nx][ny] && mapp[nx][ny] <= 'E') {
					int id = mapp[nx][ny] - 'A';
					if (((1 << id) & snake) == 0) {
						snake |= (1 << id);
						t++;
					}
				}
				else if(mapp[nx][ny] >= '0' && mapp[nx][ny] <= '9') {
					int num = mapp[nx][ny] - '0';
					if (num == key + 1) {
						key++;
					}
				}
				if (!vis[nx][ny][key][snake]) {
					vis[nx][ny][key][snake] = true;
					Q.push(node(nx, ny, t + 1, key, snake));
				}
			}
		}
	}
	if (ans == INF) {
		puts("impossible");
	}
	else {
		printf("%d\n", ans);
	}
}

int main()
{
	while (~scanf("%d%d", &n, &m) && (n || m)) {
		int cnt = 0;
		for (int i = 0; i < n; i++) {
			scanf("%s", mapp[i]);
			for (int j = 0; j < n; j++) {
				if (mapp[i][j] == 'K') {
					sx = i; sy = j;
				}
				if (mapp[i][j] == 'S') {
					mapp[i][j] = 'A' + cnt;
					cnt++;
				}
			}
		}
		bfs();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值