HDU 2709 Sumsets(递推)

传送门:点击打开链接

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2814    Accepted Submission(s): 1124


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6

就是把一个数分成2的n次方,问一共有多少种分法。

写出前10项之后,偶然就发现了规律,如果是奇数,就等于他前面的那个数,如果是偶数,就等于a[i-1]+a[i/2]。注意要模除1000000000.


代码实现:


#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

double a[1000005];
int main()
{
	int i,j,k,n;
	
	a[1]=1;a[2]=2;
	
	for(i=3;i<=1000000;i++)
	{
		if(i%2==1)
		a[i]=a[i-1];
		else
		a[i]=(int)(a[i-1]+a[i/2])%1000000000;
	}
	
	while(cin>>n)
	{
		printf("%.0lf\n",a[n]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值