HDU 2709

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2673    Accepted Submission(s): 1068


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6
 
1   2   3   4   5   6   7   8   9   10   11   12  13

1   2   2   4   4   6   6   10 10 14   14    18  18


推理可得 i%2==0时 a[i]=a[i-1]+a[i/2]    i%2!=0  a[i]=a[i-1];

具体分析

设a[n]为和为 n 的种类数;

根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:

1.n为奇数,a[n]=a[n-1]

2.n为偶数:     主要这里不好理解。。。。。。

(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];

(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n-2];

所以总的种类数为:a[n]=a[n-2]+a[n/2];



#include<bits/stdc++.h>
using namespace std;
long long int a[1000001];
#define N 1000000000;
int main()
{
    a[1]=1;
    a[2]=2;
    a[3]=2;
    a[4]=4;
    a[5]=4;
    for(int i=6;i<=1000000;i++)
    {
        if(i%2==0)
        {
            a[i]=a[i-1]+a[i/2];
            a[i]=a[i]%N;
        }
        else
        {
            a[i]=a[i-1];
            a[i]=a[i]%N;
        }
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
    printf("%lld\n",a[n]);
    }
    return 0;
}



还有一种方法 借鉴别人的方法 DP

DP思想,

假如只能用1构成那么每个数的分的方法种数就是1.

如果这个时候能用 2 构成,那么对于大于等于 的数 n 就可以由 n - 2 和 2 构成 就转化为 求 n - 2 的种数那么就是d [ n ] = d [ n-2 ] + d [ n ] (前面 d [ n-2 ] 表示数n可以由2构成的种数,后面加的 d [ n ] 表示数n只能由 构成的种数.)

那么状态转移方程式子就出来了(c [ n ] = 2^n)

d [ n ] [ k ] = d [ n ] [ k - 1 ] + d [ n - c [ k ] ] [ k ] ;

循环降维:

d [ n ] = d [ n ] + d [ n - c [ k ] ] ;

#include<stdio.h>  
#include <string.h>
__int64 d[1000005],c[25],n,i,j;  
int main()  
{  
    while(scanf("%d",&n)!=EOF) 
    {
        memset(d,0,sizeof(d));
        c[0]=d[0]=1;  
    for(i=1;i<=24;i++)  
        c[i]=c[i-1]<<1;  
    for(i=0;i<=24&&c[i]<=n;i++)  
        for(j=c[i];j<=n;j++)  
            d[j]=(d[j]+d[j-c[i]])%1000000000;  
        printf("%d\n",d[n]);
    }
            return 0;
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值