Train Problem I

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18040    Accepted Submission(s): 6736


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   2063  1015  1087  1048  1873 
include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
int main()
{
    int i,j,n;
    char a[13];
    char b[13];
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s %s",a,b);
        stack<char>s;
        j=0;
        int k=0;
        int c[100];//1 in 0 out
        for(i=0;i<n;i++)
        {
            s.push(a[i]);
            c[k]=1;
            k++;
            while(!s.empty()&&j<n)
            {
                if(s.top()==b[j])
                {
                    c[k]=0;
                    k++;
                    j++;
                    s.pop();

                }
                else
                break;
            }
        }
        if(s.empty())
        {
            printf("Yes.\n");
            for(i=0;i<k;i++)
            {
                if(c[i]==1)
                printf("in\n");
                else
                if(c[i]==0)
                 printf("out\n");
            }


        }
        else
        {
            printf("No.\n");
        }
        printf("FINISH\n");
        while(!s.empty())
        s.pop();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这个错误是由于在分类问题中,响应变量必须是分类变量,而您的响应变量可能是连续变量或其他类型的变量,因此需要进行修改。 要解决这个问题,您可以采取以下步骤: 1. 确认响应变量的类型:首先,您需要确认响应变量的类型是否正确。如果响应变量是连续变量,则需要将其转换为分类变量。 2. 指定varType:如果您使用的是OpenCV的TrainData函数来创建训练数据,则需要在创建数据对象时指定varType参数。varType是一个整数向量,指定每个特征变量的数据类型。对于分类变量,varType应该被设置为CV_VAR_CATEGORICAL,对于连续变量,应该被设置为CV_VAR_NUMERICAL。 3. 指定整数响应变量:如果您使用的是OpenCV的SVMImpl::train函数来训练模型,则需要将响应变量转换为整数。您可以使用OpenCV的convertTo函数将响应变量转换为整数类型。 例如,如果您的响应变量是一个字符串类型的变量,则可以将其转换为整数变量,如下所示: ```c++ std::vector<std::string> responses = {"category1", "category2", "category3"}; std::vector<int> intResponses; for (auto response : responses) { if (response == "category1") { intResponses.push_back(0); } else if (response == "category2") { intResponses.push_back(1); } else if (response == "category3") { intResponses.push_back(2); } } ``` 这将把响应变量转换为整数类型,并可以用于训练模型。 希望这些步骤可以帮助您解决这个问题!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值