poj1016 Prime Ring Problem---dfs

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22718    Accepted Submission(s): 10116


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
  
  
6 8

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

Source


 

 

题目大意:给你一个n,输出用1~n的数组成一个环,相邻两数之间的和为素数。

 

代码:

#include <iostream>
#include <cstring>
using namespace std;

int hash[30];
int arr[100];
int n;

int check(int x)
{
    for(int i=2;i<x;i++)
    {
        if(x%i==0)
        return 0;
    }
    return 1;
}

void dfs(int order,int index)
{
    int i;
    arr[order]=index;
    hash[index]=1;

    if(order==n)
    {
        if(check(arr[order]+arr[1]))
        {
              cout<<"1";
              for(i=2;i<=n;i++)
              cout<<" "<<arr[i];
              cout<<endl;
        }
       return;
    }

    for(i=1;i<=n;i++)
    {
        if(!hash[i]&&check(arr[order]+i))
        {
            dfs(order+1,i);
            hash[i]=0;
        }
    }
    return;
}
int main()
{
    int flag=1;
    while(cin>>n)
    {
        cout<<"Case "<<flag++<<":"<<endl;

        memset(hash,0,sizeof(hash));
        dfs(1,1);

        cout<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值