1093 Count PAT‘s (25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路解析:

本题如果直接采用暴力算法会导致运行超时。

因此本题的思想如下,遍历字符串,对字符串中的每个A,统计其左侧有多少个P,右侧有多少个T,这两个数的乘积即为以这个A形成的PAT的个数num,然后依次累加每个A对应的num。

注意:记得对所求结果进行取余,否则可能会导致结果错误。

 代码:

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    char PAT[100010];
    scanf("%s",PAT);
    int count_A=0,count=0,count_P[100010]={0},count_T[100010]={0},temp;
    int len=strlen(PAT);
    for(int i=0;i<len;i++)
    {
        if(PAT[i]=='P')
            count++;
        else if(PAT[i]=='A')
        {
            count_A++;
            count_P[count_A]=count;
        }
    }
    count=0;
    temp=count_A;
    for(int i=len-1;i>=0;i--)
    {
        if(PAT[i]=='T')
            count++;
        else if(PAT[i]=='A')
        {
            count_T[count_A]=count;
            count_A--;
        }
    }
    count=0;
    for(int i=0;i<=temp;i++)
        count=(count+count_P[i]*count_T[i])%1000000007;
    printf("%d",count);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值