The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n[1]^P + ... n[K]^P
where n[i]
(i
= 1, ..., K
) is the i
-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12^2+4^2+2^2+2^2+1^2, or 11^2+6^2+2^2+2^2+2^2, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,⋯,aK } is said to be larger than { b1,b2,⋯,bK } if there exists 1≤L≤K such that ai=bi for i<L and aL>bL.
If there is no solution, simple output Impossible
.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
代码:
#include<iostream>
#include<vector>
using namespace std;
int N,K,P;
vector<int > ans,temp,fac;
int maxsum=-1;
int power(int x)
{
int ans=1;
for(int i=0;i<P;i++)
ans*=x;
return ans;
}
void init()
{
int t=0,i=1;
while(t<=N)
{
fac.push_back(t);
t=power(i++);
}
}
void DFS(int index,int k,int sum,int n)//index存放下标,k存放个数,sum存放和,n和N对应
{
if(k>K||n>N)
return;
if(k==K&&n==N)
{
if(sum>maxsum)
{
ans=temp;
maxsum=sum;
}
return;
}
if(index-1>=0)
{
temp.push_back(index);
DFS(index,k+1,sum+index,n+fac[index]);
temp.pop_back();
DFS(index-1,k,sum,n);
}
}
int main()
{
scanf("%d%d%d",&N,&K,&P);
init();
DFS(fac.size()-1,0,0,0);
if(maxsum==-1)
printf("Impossible");
else{
printf("%d = ",N);
for(int i=0;i<ans.size();i++)
{
if(i!=0)
printf(" + %d^%d",ans[i],P);
else
printf("%d^%d",ans[0],P);
}
}
return 0;
}