codeforces 631B Print Check

Kris works in a large company "Blake Technologies". As a best engineer of the company he was assigned a task to develop a printer that will be able to print horizontal and vertical strips. First prototype is already built and Kris wants to tests it. He wants you to implement the program that checks the result of the printing.

Printer works with a rectangular sheet of paper of size n × m. Consider the list as a table consisting of n rows and m columns. Rows are numbered from top to bottom with integers from 1 to n, while columns are numbered from left to right with integers from 1 to m. Initially, all cells are painted in color 0.

Your program has to support two operations:

  1. Paint all cells in row ri in color ai;
  2. Paint all cells in column ci in color ai.

If during some operation i there is a cell that have already been painted, the color of this cell also changes to ai.

Your program has to print the resulting table after k operation.

Input

The first line of the input contains three integers n, m and k (1  ≤  n,  m  ≤ 5000, n·m ≤ 100 000, 1 ≤ k ≤ 100 000) — the dimensions of the sheet and the number of operations, respectively.

Each of the next k lines contains the description of exactly one query:

  • ri ai (1 ≤ ri ≤ n, 1 ≤ ai ≤ 109), means that row ri is painted in color ai;
  • ci ai (1 ≤ ci ≤ m, 1 ≤ ai ≤ 109), means that column ci is painted in color ai.

Output

Print n lines containing m integers each — the resulting table after all operations are applied.

Sample Input

Input
3 3 3
1 1 3
2 2 1
1 2 2
Output
3 1 3 
2 2 2 
0 1 0 
Input
5 3 5
1 1 1
1 3 1
1 5 1
2 1 1
2 3 1
Output
1 1 1 
1 0 1 
1 1 1 
1 0 1 
1 1 1 

Sample Output

Hint

The figure below shows all three operations for the first sample step by step. The cells that were painted on the corresponding step are marked gray.



题目意思很简单,就是模拟,问题是暴力会超时。
一开始我是用了很复杂的方法(当然有些正确方法的影子),主要是正确方法的一个点没想到。
什么点呢?一开始我纠结的就是一个点如果被涂了多次怎么办,一直做不出来。
正确做法就是,每次涂色都记录步数,并更新当前行/列的值,最后比较一下就可以了(注意没有涂过的情况)

下面贴代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>

using namespace std;
int a[5010][5010];
struct myk{
int num;
int bianhao;};
int m,n,k;
myk zuizhonghang[5010],zuizhonglie[5010];
void paint(int cixu,int x,int i,int j)
{
    if(x==1)
    {
        zuizhonghang[i].num=j;
        zuizhonghang[i].bianhao=cixu;
    }
    if(x==2)
    {

        zuizhonglie[i].num=j;
        zuizhonglie[i].bianhao=cixu;
    }
}
int main(void)
{
    int aa,b,c;
    scanf("%d%d%d",&n,&m,&k);
    memset(a,0,sizeof(a));
    for(int i=1;i<=5000;i++)
    {
        zuizhonghang[i].bianhao=0;
        zuizhonglie[i].bianhao=0;
    }
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d%d",&aa,&b,&c);
        paint(i,aa,b,c);
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if((zuizhonghang[i].bianhao==0)&&(zuizhonglie[j].bianhao==0))
                a[i][j]=0;
            else
                a[i][j]=(zuizhonghang[i].bianhao>zuizhonglie[j].bianhao)?zuizhonghang[i].num:zuizhonglie[j].num;
            printf("%d ",a[i][j]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值