哈希 poj2752 Seek the Name, Seek the Fame

该博客详细解析了POJ2752编程题的解决方案,重点在于如何运用哈希算法解决字符串查找问题。通过实例输入和输出,博主展示了哈希函数的设计思路,帮助读者理解哈希冲突的处理方法及其在实际问题中的应用。
摘要由CSDN通过智能技术生成

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17568 Accepted: 9009

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source


第一道哈希模板题,WA了好多发,写个题解吧。
首先做法很简单,哈希预处理,枚举长度即可。
下面是需要注意的点:
1.哈希的mod的处理,选一个比较好的数,而且注意运算过程中取模运算,同时注意负数取模
2.expp【】数组要开成字符串规模大小!
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<set>
#include<algorithm>
using namespace std;
const long long MOD=1000000000+27;
char s[400000+10];
long long a[400000+10],n,expp[400000+10];//expp[i] means 31^i
void init(void)
{
    expp[0]=1;
    for(int i=1;i<400000+10;i++)
        expp[i]=(expp[i-1]*31)%MOD;
}
int main(void)
{
    init();
    while(scanf("%s",s+1)!=EOF)
    {
        memset(a,0,sizeof(a));
        a[0]=0;
        n=strlen(s+1);
        a[1]=(s[1]-'a'+1);
        for(int i=2;i<=n;i++)
        {
            a[i]=(a[i-1]+expp[i-1]*(s[i]-'a'+1))%MOD;
        }
        for(int i=1;i<=n;i++)
        {
            long long tempa=(a[i])%MOD,tempb=(a[n]-a[n-i]+MOD)%MOD;
            if((tempa*expp[n-i])%MOD==tempb)
                printf("%d ",i);
        }
        printf("\n");
    }
    return 0;
}

3.每一位的权值不要是0,否则0000 与0 无法分辨。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值