This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
/**
2017.3.6
Donald
*/
//1009. Product of Polynomials (25)
/**
Tips:
数组开平方
*/
#include<cstdio>
using namespace std;
#define EPS 1e-10
#define MAXN 1000001
double A[MAXN];
double B[MAXN];
double Ans[MAXN];
void solve(int STARTA, int STARTB){
for(int i = STARTA; i >= 0; --i){
for(int j = STARTB; j >= 0; --j){
Ans[i + j] += A[i] * B[j];
}
}
int cnt = 0;
for(int i = MAXN - 1; i >= 0; --i){
if(!(Ans[i] >= -EPS && Ans[i] <= EPS))
cnt++;
}
printf("%d", cnt);
for(int i = MAXN - 1; i >= 0; i--)
if(!(Ans[i] >= -EPS && Ans[i] <= EPS))
printf(" %d %.1lf", i, Ans[i]);
}
int main(void){
int K;
int N;
int startA, startB;
scanf("%d", &K);
scanf("%d", &N);
startA = N;
scanf("%lf", &A[N]);
for(int i = 1; i < K; ++i){
scanf("%d", &N);
scanf("%lf", &A[N]);
}
scanf("%d", &K);
scanf("%d", &N);
startB = N;
scanf("%lf", &B[N]);
for(int i = 1; i < K; ++i){
scanf("%d", &N);
scanf("%lf", &B[N]);
}
solve(startA, startB);
return 0;
}