40:Distinct

40:Distinct

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Select some of N values. The selected values are all different and the number of the selected values is maximum.

输入

First line: one positive integers N (N <= 100).
Second line: N positive integers (<= 10000).

输出

One line contains several selected values.

样例输入

7
2 2 5 1 2 1 7

样例输出

2 5 1 7
  • 查看
  • 提交
  • 统计
  • 提问
  • #include<cstdio>
    #include<iostream>
    using namespace std;
    int a[10005]={0};//元素a[i]=0表示值i在之前没有出现过
    int main(){
    	int n;
    	cin>>n;
    	for(int i=1;i<=n;i++){
    		int m;
    		cin>>m;
    		if(!a[m]){//判断m是否在之前出现过
    			cout<<m<<' ';
    			a[m]++;//a[m]!=0为后面相同值m出现做下一次判断
    		} 
    	}
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

fanlangke

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值