HDU 2955 推荐 抢银行+01背包变形

HDU 2955 推荐

Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Appoint description:

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

解题思路:
以前做过一个浮点数的01背包,开始感觉和那一题类似的思路,把浮点数转化成整数来做
实际上不是,这题的精度大了去了,抱着试一试的态度果然wa了一发
1,转换思路,重新设计状态转移方程
2,设计的思路是:抢到钱i时,不被抓的概率dp[i]
3,dp[0] = 1;状态转移方程就是dp[j] = max(dp[j],dp[j-v[i]]*p[i]) ;   
4,代码中P和p[]数组都是拿1减了一下,表示不被抓的概率
5,最后在循环结束后的dp数组中找到第一个大于等于P的输出即可
仔细看看那个方程,很好理解吧

#include<bits/stdc++.h>
using namespace std;
const int maxn = 105 ;
int v[maxn];
double p[maxn];
double dp[10005];
int main(){
    int T,n;
    double P ;
    scanf("%d",&T);
    while(T--){
        scanf("%lf %d",&P,&n) ;
        P = 1-P ;
        int tot= 0 ;
        for(int i=1;i<=n;i++){
            scanf("%d%lf",&v[i],&p[i]);
            p[i] = 1-p[i] ;
            tot+=v[i] ;
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1 ;
        for(int i=1;i<=n;i++){
            for(int j=tot;j>=v[i];j--){
                dp[j] = max(dp[j],dp[j-v[i]]*p[i]) ;
            }
//            for(int j = 0;j<=tot;j++){
//                printf("%lf ",dp[j]);
//            }printf("\n");
        }
        int ans = 0 ;
        for(int i = tot;i>=0;i--){
            //printf("%lf %lf\n",dp[i],P);
            if(dp[i]>=P){
                ans = i ;
                break;
            }
        }
        printf("%d\n",ans) ;
    }
    return 0;

}



   
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值