1503 Integer Inquiry

Integer Inquiry
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25308 Accepted: 9827

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source


大数加法,10年的时候就看到华科复试有这么个题目,原来还是有出处的。显然用c/c++甚至java中内置的任何数据类型都不行,都会超出范围。只能用字符串保存输入数据了,而计算过程就需要自己模拟加法过程,一位一位的加,考虑进位等。
用栈实现起来较为方便,当然自己用数组也行。
后面应该还有高精度(浮点数)乘法,原理类似。
代码如下:
#include <iostream>
#include <stack>


using namespace std;

string add(const string &a, const string &b)
{
    //string res;
    stack<char> sa,sb,sc;
    int carry=0;

    size_t its=0;
    while(its!=a.length())
    {
        sa.push(a[its]);
        its++;
    }
    its=0;
    while(its!=b.length())
    {
        sb.push(b[its]);
        its++;
    }

    while(!sa.empty() && !sb.empty())
    {
        int t = sa.top()-'0' + sb.top()-'0'+carry;
        if(t>9)
        {
            carry = 1;
            t -= 10;
        }
        else
        {
            carry = 0;
        }
        sc.push(t+'0');
        sa.pop();
        sb.pop();
    }
    while(!sa.empty())
    {
        int t = sa.top()-'0'+carry;
        if(t>9)
        {
            carry = 1;
            t -= 10;
        }
        else
        {
            carry =0;
        }
        sc.push(t+'0');
        sa.pop();
    }
    while(!sb.empty())
    {
        int t = sb.top()-'0'+carry;
        if(t>9)
        {
            carry = 1;
            t -= 10;
        }
        else
        {
            carry=0;
        }
        sc.push(t+'0');
        sb.pop();
    }
    if(carry)
        sc.push('1');

    string res;
    while(!sc.empty())
    {
        res.push_back(sc.top());
        sc.pop();
    }
    return res;

}

int main()
{
    string str;
    string res;

    while(cin>>str)
    {
        if(str=="0")
            break;
        res=add(res,str);

    }
    cout<<res<<endl;

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值