Daily Compulsory Course
[2020/05/21]
Problem 1000
coefficient of difficulty:simple input and output
A+B Problem
- Time Limit: 1000MS
- Memory Limit: 10000K
- Total Submissions: 504351
- Accepted: 284571
Description: Calculate a+b
Input: Two integer a,b (0<=a,b<=10)
Output :Outputa+b
Sample Input :1 2
Sample Output :3
Java Points:
Class Scanner for reading interger:
Scanner in = new Scanner(System.in);
int a = in.nextInt();
int b = in.nextInt();
Problem 1001
coeficient of difficulty: simple input and master of some basic class
Exponentiation
- Time Limit: 500MS
- Memory Limit: 10000K
- otal Submissions: 193661
- Accepted: 46400
Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
Solution
import java.math.BigDecimal;
import java.util.*;
public class Main {
public static void main(String[] args) throws InterruptedException {
// write your code here
Scanner cin = new Scanner(System.in);
while(cin.hasNext()){
BigDecimal a = cin.nextBigDecimal();
int b = cin.nextInt();
String res = a.pow(b).stripTrailingZeros().toPlainString();
res = (res.indexOf("0.")==0)?(res.substring(1)):res;
System.out.println(res);
}
}
}
Java Points
1. Function next() in Class Scanner:
The result of code below :
Scanner in = new Scanner(System.in);
String a = in.next();
String b = in.next();
When getting an input:
Great commodities!
Variables a and b will respectively storage:
a : "Great"
b : "commodities!"
Summary: in.next() can read strings devided by space into corresponding variables.
2. Class in Java for accurate calculation:
Java provides a class BigDecimal for precise compute, and this class has some useful functions:
- stripTrailingZeros(): strip Insignificant zeros at the tail of a big decimal.
- toPlainString(): convert BigDecimal to String not formatted with scientific notation .
- pow(): power function of the BigDecimal.
Notation: Use function nextBigDecimal() in class Scanner to read a big decimal.
3. Tips of input in the question stem:
Here it requires a set of pairs of values rather than a pair of values, so we need give it a circulation to read.
4. Spliting a string with “.”:
Use escape character to accomplish it as follow:
String[] strings = resultBigDecimal.split("\\.");
Otherwise strings array’s length will be zero.
Notation: When matching “. { [ ( ? $ ^ *” these peculiar character, add "\"before them.
5. Presentation Error:
It means your data is correct but is not formatted in proper way.