A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes
if N is a reversible prime with radix D, or No
if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
思路:判断素数,十进制数转换为N进制数
代码:
#include<iostream>
#include<math.h>
#include<queue>
using namespace std;
bool prim(int n)
{
if(n==1)
return 0;
else if(n==2||n==3)
return 1;
else
{
for(int i=2;i<=sqrt(n);i++)
{
if(n%i==0)
return 0;
}
}
return 1;
}
int chg(int n,int a)
{
int mun=0;
while(n!=0)
{
mun=mun*a+n%a;
n=n/a;
}
return mun;
}
int main()
{
int n,a;
while(1)
{
cin>>n;
if(n<0)
break;
cin>>a;
if(prim(n))
{
//int m=cmp(n,a);
int m=chg(n,a);
if(prim(m))
{
cout<<"Yes"<<endl;
}
else
cout<<"No"<<endl;
}
else
cout<<"No"<<endl;
}
return 0;
}