Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None
instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
题意:找到第一个出现的不重复的数字。
思路:用两个数组,一个保存输入数据,一个记录每个数字出现的次数。
#include<iostream>
#include<vector>
using namespace std;
const int maxn = 10000 + 5;
int arry[maxn];
vector<int> v;
int main()
{
int n;
cin >> n;
for (int i = 0; i < n; i++)
{
int x;
cin >> x;
v.push_back(x);
arry[x]++;
}
for (int i = 0; i < n; i++)
{
if (arry[v[i]] == 1)
{
cout << v[i];
return 0;
}
}
cout << "None" << endl;
return 0;
}