Time Limit: 1000 ms Memory Limit: 32768 KiB
Problem Description
在2×n的一个长方形方格中,用一个1× 2的骨牌铺满方格,输入n ,输出铺放方案的总数. 例如n=3时,为2× 3方格,骨牌的铺放方案有三种,如下图:
Input
输入数据由多行组成,每行包含一个整数n,表示该测试实例的长方形方格的规格是2×n (0< n<=50)。
Output
对于每个测试实例,请输出铺放方案的总数,每个实例的输出占一行。
Sample Input
1 3 2
Sample Output
1 3 2
Hint
hdoj2046 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
Source
HDU LCY
#include <iostream>
#include <vector>
using namespace std;
int main()
{
int n;
const int x = 55;
vector<long long int> a(55);
a[1] = 1;
a[2] = 2;
for (int i = 3; i < x; i++)
{
a[i] = a[i - 1] + a[i - 2];
}
while (cin >> n)
{
cout << a[n] << endl;
}
}