(hdu1005)Number Sequence(组合数学)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 176298 Accepted Submission(s): 43607

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

题意:定义:f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 给A,B,n三个数,问f(n)是多少?
分析:这应该属于组合数学的问题,如果你注意到mod7,每个数的范围都是0-6,两个数组合一共有49种结果,然后直接递归

#include<cstdio>
#include<cstring>
using namespace std;
int f(int a,int b,int n)
{
    if(n==1||n==2)
        return 1;
    else
        return (a*f(a,b,n-1)+b*f(a,b,n-2))%7;
}
int main()
{
    int n,a,b;
    while(~scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
    {
        printf("%d\n",f(a,b,n%49));
    }
    return 0;
}

优化:
记忆存储

#include<cstdio>
#include<cstring>
using namespace std;
const int N=50;
int A[N];
int dfs(int a,int b,int n)
{
    if(n==1||n==2) return 1;
    int& ret=A[n];
    if(ret!=-1) return ret;
    return ret=(a*dfs(a,b,n-1)+b*dfs(a,b,n-2))%7;
}
int main()
{
    int n,a,b;
    while(~scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
    {
        memset(A,-1,sizeof(A));
        printf("%d\n",dfs(a,b,n%49));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值