Parenthesis(括号平衡串,匹配问题)

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S’ such that S=(S’).
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).
Output
For each question, output ” Yes” if P remains balanced, or ” No” otherwise.
Sample Input
4 2
(())
1 3
2 3
2 1
()
1 2
Sample Output
No
Yes
No

题意:给定一个长度为n的括号平衡串,q次交换,问交换后是不还是平衡串? 是输出Yes,不是输出No。

分析: 未交换时,就是一个平衡串,即括号都能够匹配
那么 交换的位置 可能有以下几种情况:
1.原来就是一样的 或者 左边的是’)’,右边的是’(’ 直接特判 (少一种判断会TLE)
2.左边的是’(’ ,右边的是’)’ 计数判断

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mod=10056;
const int N=1e5+5;
typedef long long LL;
#define mem(a,n) memset(a,n,sizeof(a))
char str[N];
int main()
{
    int n,q;
    while(~scanf("%d%d",&n,&q))
    {
        scanf("%s",str);
        for(int i=0; i<q; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(str[a-1]==str[b-1])
            {
                puts("Yes");
                continue;
            }
            if(a>b) swap(a,b);
            if(str[a-1]==')'&&str[b-1]=='(')
            {
                puts("Yes");
                continue;
            }
            swap(str[a-1],str[b-1]);
            int ans=0;
            for(int i=0; i<n; i++)
            {
                if(str[i]=='(')
                    ans++;
                else ans--;
                if(ans<0) break;
            }
            printf("%s\n",ans?"No":"Yes");
            swap(str[a-1],str[b-1]);///  还要换回去!
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: 以下是Python编写的匹配左右圆括号的代码: ```python def check_parenthesis(string): """ 检查圆括号是否匹配 """ stack = [] # 用栈来存储左括号的位置 for i in range(len(string)): if string[i] == '(': stack.append(i) elif string[i] == ')': if len(stack) == 0: return False stack.pop() return len(stack) == 0 # 测试case print(check_parenthesis('()')) # True print(check_parenthesis('(()())')) # True print(check_parenthesis('(())(')) # False print(check_parenthesis(')(')) # False ``` ### 回答2: Python可以通过使用栈来判断左右圆括号是否匹配。 首先,我们创建一个空栈,然后遍历给定的编码。如果遇到左圆括号('('),我们将其放入栈中。如果遇到右圆括号(')'),则需要检查栈是否为空。如果栈为空,则表示右圆括号与前面没有对应的左圆括号,因此不匹配。如果栈不为空,则从栈中弹出一个左圆括号,表示找到了对应的配对。遍历完成后,如果栈不为空,也表示存在未配对的左圆括号,所以不匹配。 以下是一个示例函数来检查左右圆括号匹配: def check_parentheses(code): stack = [] for char in code: if char == '(': stack.append(char) elif char == ')': if len(stack) == 0: return False stack.pop() return len(stack) == 0 该函数接受一个编码字符作为参数,并返回一个布尔值,表示括号是否匹配。当遇到左圆括号时,将其推入栈中,当遇到右圆括号时,弹出栈顶的左圆括号。最后,检查栈是否为空,以确定括号是否完全匹配。 该函数的运行时间与代码中括号的数量成线性关系,所以时间复杂度为O(n),其中n是编码中圆括号的总数。 ### 回答3: 编写一个程序来检测给定字符中的左右圆括号是否匹配。 首先,我们可以声明一个栈来存储左圆括号。然后我们遍历给定的字符,如果遇到左圆括号,我们将其推入栈中。如果遇到右圆括号,我们检查栈是否为空。如果栈不为空,则弹出栈顶元素,表示找到了匹配的左圆括号。否则,我们就得出左右圆括号匹配。 最后,我们需要检查栈是否为空。如果栈不为空,则意味着存在无法匹配的左圆括号,即左右圆括号匹配。如果栈为空,则表示所有的左右圆括号匹配。 这个算法的时间复杂度为O(n),其中n是字符的长度。以下是使用Python编写的示例代码: ```python def check_parentheses(s): stack = [] for char in s: if char == '(': stack.append(char) elif char == ')': if len(stack) > 0: stack.pop() else: return False return len(stack) == 0 # 测试代码 s1 = "((()))" # 左右圆括号匹配 s2 = "(()))" # 左右圆括号匹配 print(check_parentheses(s1)) # 输出:True print(check_parentheses(s2)) # 输出:False ``` 通过这个算法,我们可以判断给定字符中的左右圆括号是否匹配

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值