Parenthesis(括号平衡串,匹配问题)

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S’ such that S=(S’).
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).
Output
For each question, output ” Yes” if P remains balanced, or ” No” otherwise.
Sample Input
4 2
(())
1 3
2 3
2 1
()
1 2
Sample Output
No
Yes
No

题意:给定一个长度为n的括号平衡串,q次交换,问交换后是不还是平衡串? 是输出Yes,不是输出No。

分析: 未交换时,就是一个平衡串,即括号都能够匹配
那么 交换的位置 可能有以下几种情况:
1.原来就是一样的 或者 左边的是’)’,右边的是’(’ 直接特判 (少一种判断会TLE)
2.左边的是’(’ ,右边的是’)’ 计数判断

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mod=10056;
const int N=1e5+5;
typedef long long LL;
#define mem(a,n) memset(a,n,sizeof(a))
char str[N];
int main()
{
    int n,q;
    while(~scanf("%d%d",&n,&q))
    {
        scanf("%s",str);
        for(int i=0; i<q; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            if(str[a-1]==str[b-1])
            {
                puts("Yes");
                continue;
            }
            if(a>b) swap(a,b);
            if(str[a-1]==')'&&str[b-1]=='(')
            {
                puts("Yes");
                continue;
            }
            swap(str[a-1],str[b-1]);
            int ans=0;
            for(int i=0; i<n; i++)
            {
                if(str[i]=='(')
                    ans++;
                else ans--;
                if(ans<0) break;
            }
            printf("%s\n",ans?"No":"Yes");
            swap(str[a-1],str[b-1]);///  还要换回去!
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值