【PAT甲级】1085 Perfect Sequence (25)(二分法)

题目链接

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 10^5^) is the number of integers in the sequence, and p (<= 10^9^) is the parameter. In the second line there are N positive integers, each is no greater than 10^9^.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思路:通过枚举序列最小值,二分查找满足题目条件的序列最大值对应的位置,取连续序列的最大长度

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e5+5;

int a[N];
int main() {
    int n,p;
    cin>>n>>p;
    for(int i=0; i<n; i++) cin>>a[i];
    sort(a,a+n);
    int hi=n-1,lo=0,anscount=0;
    for(int i=0; i<n; i++) {///枚举序列的最小值
        ll maxx=1LL*a[i]*p;///long long 防溢出
        if(maxx>a[n-1]) {///序列已经不满足题目条件M<=m*p,即maxx已经到最大值
            anscount=max(anscount,n-i);
            break;
        }
        hi=n-1;
        int mid;
        while(lo<hi) {///二分找 当最小值为a[i]时,最大值M对应的位置mid
            mid=(lo+hi)>>1;
            if(maxx<a[mid]) hi=mid;
            else if(maxx>a[mid]) lo=mid+1;
            else {
                break;
            }
        }
        anscount=max(anscount,mid-i+1);
        lo=mid+1;
    }
    cout<<anscount;
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值