【PAT甲级】1145 Hashing - Average Search Time(25 分)(平方探测法)

题目链接

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

题意:给定Msie,n,m分别为Hash表的大小,插入的数的个数,查找的数的个数。(Msize是大于自身的最小素数)如果找到查询的数,输出平均查找次数,否则输出”X cannot be inserted“

相似题目:【PAT甲级】1078 Hashing(25 分)(平方探测法)

思路:处理冲突:平方探测法 pos=(x+j*j)%Msize,j取值-1,0,1,2,3,4.此题只考虑正增长(

Quadratic probing (with positive increments only) is used to solve the collisions.

代码:

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <cstdio>
#include <string>
#include <vector>
#include <climits>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e3+5;

bool isPrime(int x) {
    if(x<=1) return false;
    for(int i=2; i*i<=x; i++) {
        if(x%i==0) return false;
    }
    return true;
}
int quadraticProb(int x,int j,int Msize) {
    return (x+j*j)%Msize;
}
int main() {
    int Msize,n,m;
    scanf("%d%d%d",&Msize,&n,&m);
    while(!isPrime(Msize)) {
        Msize++;
    }
    vector<int>vec(Msize);
    int x;
    for(int i=0; i<n; i++) {
        scanf("%d",&x);
        bool flag=0;
        for(int j=0; j<Msize; j++) {
            int pos=quadraticProb(x,j,Msize);
            if(vec[pos]==0) {
                vec[pos]=x;
                flag=1;
                break;
            }
        }
        if(!flag) {
            printf("%d cannot be inserted.\n",x);
        }
    }
    double ans=0;
    for(int i=0; i<m; i++) {
        scanf("%d",&x);
        int cnt=0;
        bool flag=0;
        for(int j=0; j<Msize; j++) {
            cnt++;
            int pos=quadraticProb(x,j,Msize);
            if(vec[pos]==x||vec[pos]==0) {
                flag=1;
                break;
            }
        }
        if(!flag) {///在Hash Table中没找到 +1
            cnt++;
        }
        ans+=cnt;
    }
    printf("%.1lf\n",ans/m);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值