【PAT甲级】1078 Hashing(25 分)(平方探测法)

题目链接
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意:给出散列表的长度Msize和欲插入的元素,将这些元素按顺序插入散列表,散列函数为H(key) = key % tsize,解决冲突采用只往正向增加的二次探查法。 如果Msize不是素数,需要将Msize重新赋值为第一个比Msize大的素数再插入。

相似题目:【PAT甲级】1145 Hashing - Average Search Time(25 分)(平方探测法)

思路:先判断Msize是否为素数,不是则按照题意调整为素数;再按照散列函数公式判断是否冲突,不冲突则插入;冲突则用平方探测法解决冲突,然后插入 并且输出插入的位置。

代码:

#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e4+5;

bool isPrime(int x) {
    if(x<=1) return false;
    for(int i=2; i*i<=x; i++) {
        if(x%i==0) return false;
    }
    return true;
}
int quadraticProb(int x,int j,int Msize) {
    return (x+j*j)%Msize;
}
bool vis[N];
int main(){
    int Msize,n;
    scanf("%d%d",&Msize,&n);
    while(!isPrime(Msize)){
        Msize++;
    }
    for(int i=0;i<n;i++){
        int key;
        scanf("%d",&key);
        int id=quadraticProb(key,0,Msize);
        if(!vis[id]){
            vis[id]=1;
            if(i) printf(" ");
            printf("%d",id);
        }else {
            bool flag=0;
            for(int j=1;j<Msize;j++){
                id=quadraticProb(key,j,Msize);
                if(!vis[id]){
                    vis[id]=1;
                    flag=1;
                    if(i) printf(" ");
                    printf("%d",id);
                    break;
                }
            }
            if(!flag){
                if(i) printf(" ");
                printf("-");
            }
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值