【PAT甲级】1061 Dating(20 分)

题目链接
Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

题意:

给定四个字符串,由str1和str2相同位置上且该位置为相同大写字母决定星期,由第二个相同数字或大写字母决定小时,由str3和str4相同位置上的相同字母的位置决定分钟; 输出对应时间。

思路:模拟,注意是相同的位置

代码:

#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;

map<char,string>mp;
void init() {
    mp['A']="MON",mp['B']="TUE";
    mp['C']="WED",mp['D']="THU";
    mp['E']="FRI",mp['F']="SAT";
    mp['G']="SUN";
}
int main() {
    string str1,str2,str3,str4;
    cin>>str1>>str2>>str3>>str4;
    init();
    int i,len1=min(str1.size(),str2.size());
    for(i=0; i<len1; i++) {
        if(str1[i]==str2[i]&&str1[i]>='A'&&str1[i]<='G') {
            cout<<mp[str1[i]];
            break;
        }
    }
    for(i++; i<len1; i++) {
        if(str1[i]==str2[i]) {
            if(str1[i]>='A'&&str2[i]<='N') {
                printf(" %02d:",10+str1[i]-'A');
                break;
            } else if(isdigit(str1[i])){
                printf(" %02d:",str1[i]-'0');
                break;
            }
        }
    }
    int len2=min(str3.size(),str4.size());
    for(int i=0; i<len2; i++) {
        if(str3[i]==str4[i]&&isalpha(str3[i])) {
            printf("%02d",i);
            break;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值