HDU 4135 Co-prime

Co-prime
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3507 Accepted Submission(s): 1388

Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

Sample Input
2
1 10 2
3 15 5

Sample Output
Case #1: 5
Case #2: 10

HintIn the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
题意:求a~b之间有多少数与n互质
题解:先求出 n 的质因子并用数组存起来,然后求出1~m内有多少与n不互质的数,相减的答案
质因子:能被 n 整除并且本身是质数的
互质: a 与 b 互质表示a 与 b 的相同质因子只有一个 1, 两者不一定是质数;

#include <cstdio>
#define LL __int64
#define M 11000

LL p[M];//保存质因子 
int k;//记录质因子个数 
void zhiyz(LL n)//找出n的质因子 
{
    k = 0;
    for(int i=2; i*i<=n; i++)
    {
        if(n % i == 0)
        {
            p[k++] = i;//保存质因子 
        }
        while(n % i == 0)
        {
            n /= i;//质因子的倍数全部剔除 
        }
    }
    if(n > 1)
    {
        p[k++] = n;//n是质数 
    }
}
LL nop(LL m)//计算 1 ~ m 的中与 n 不互质的个数 
{
    LL top = 0;//队列顶点 
    LL que[10100];
    LL i, j, t;
    que[top++] = -1;//记录质因子出现的次数 
    for(i=0; i<k; i++)
    {
        t = top;//便于计算 
        for(j=0; j<t; j++)
        {
            que[top++] = que[j] * p[i] * -1;//出现奇次就加,偶数次就减 因为 j 从零开始,所以两个质因数的积(表示重复)就记录为负数,将在下面减去 
        }
    }
    LL sum = 0;//统计个数
    for(i=1; i<top; i++)
    {
        sum += m / que[i];//加上所有的,并减去重复的 
    }

    return sum;
}
int main()
{
    int t;
    LL a, b, n;
    scanf("%d", &t);
    for(int ca=1; ca<=t; ca++)
    {
        scanf("%I64d%I64d%I64d", &a, &b, &n);
        zhiyz(n);
        LL ans = b - a + 1 - nop(b) + nop(a-1);
        printf("Case #%d: %I64d\n", ca, ans);
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值