28:Sum Number

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Given a sequence of N number. How many numbers in the sequence are there which equal to the sum of two different numbers in the sequence.

输入

First line: one positive integers N (N <= 100).
Second line: N positive integers (<= 100000).

输出

One integer.

样例输入

4
1 3 4 2

样例输出

2

#include<bits/stdc++.h>//Writed by Wangzhimin Date: 2022.06.06 
using namespace std;
int num,k,a[105];
int main()
{
    scanf("%d",&num);
    int cnt=0,sum,i,j;
    for(int i=0;i<num;i++)
        scanf("%d",&a[i]);//输入数据 
        sort(a,a+num);//排序 
    for(i=0;i<num-2;i++)
        for(j=i+1;j<num-1;j++)    //依次把两个数相加 
        {
            sum=a[i]+a[j];
            if(sum<=a[num-1])//如果相加的和小于等于最大的数才行 
            {
                for(int t=j+1;t<num;t++)
                if(sum==a[t])//从第二个加数后(因为后面的数大)找 
                {
                    cnt++;
                    break;
                }
            }
              } 
              cout<<cnt;//输出两个数相加等于输入数的量     
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值