POJ 2492---A Bug‘s Life(种类并查集)

http://poj.org/problem?id=2492
Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

题意:
输入臭虫之间的对象,要求出是否出现了同性的关系

思路
种类并查集
x和 x+n 代表对立的性别(相当于另类的表示)
我们讲同性的虫子放到同一个集合,我们每次输入的都应该是异性的虫子,这时我们加入判断,如果两个本该异性的虫子,在同一集合,那么说明出了问题。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <string>
#include <sstream>
#include <stack>
#include <queue>
#include <map>

using namespace std;
const int inf=0x3f3f3f3f;
const int MAX=2e3+5;
int t,n,m,a,b;
int father[MAX*2];
int find(int a)
{
	int x=a;
	while (a!=father[a]) {
		a=father[a];
	}
	while (x!=father[x]) {
		int z=x;
		x=father[x];
		father[z]=a;
	}
	return a;
}
int Union(int a,int b)
{
	int x,y;
	x=find(a);
	y=find(b);
	if(x!=y){
		father[x]=y;
	}
	return 0;
}
bool judge(int a,int b)
{
	int x=find(a);
	int y=find(b);
	if(x!=y)	return true;
	else		return false;
}
int main()
{
	ios::sync_with_stdio(false);
	cin>>t;
	for (int k=1;k<=t;k++) {
		cin>>n>>m;
		for (int i=0;i<=2*n;i++)	father[i]=i;
		bool flag=false;
		for (int i=0;i<m;i++) {
			cin>>a>>b;
			if(judge(a,b)&&judge(a+n,b+n)){
				Union(a,b+n);
				Union(b,a+n);
			}else{
				flag=true;
			}
		}
		if(k!=1)	cout<<endl;
		printf("Scenario #%d:\n",k);
        if(!flag)
            printf("No suspicious bugs found!\n");
        else
            printf("Suspicious bugs found!\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值