POJ-2253 Frogger (Dijkstra)

. Freddy Frog is sitting on a stone in the middle of a lake. Suddenly
he notices Fiona Frog who is sitting on another stone. He plans to
visit her, but since the water is dirty and full of tourists’
sunscreen, he wants to avoid swimming and instead reach her by
jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach
her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in
the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range
over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog
distance between Freddy’s and Fiona’s stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

/*题意描述:给出n个坐标第一个代表第一个青蛙第二个坐标代表第二个青蛙,其它坐标为其它的石头,现在第一个青蛙要去第二个哪里问最短的蛙距是多少。这里千万不要理解为是第一个青蛙到第二个青蛙的最短路径。这个是第一个青蛙到第二青蛙所有路线中的,某一段的最短距离。呵呵说了这么多的废话下边看代码吧!

#include<stdio.h>
#include<string.h>
#include<math.h>

struct node
{
	int x,y;
}p[210];

double max(double a,double b)
{
	if(a>b)
		return a;
	else
		return b;
}

int main(void)
{
	double inf=99999999;
	int book[210];
	double e[210][210],dis[210],min;
	int n,i,j,u;
	int t=1;
	while(~scanf("%d",&n))
	{
		if(n==0)
			break;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(i==j) e[i][j]=0;
				else e[i][j]=inf;
		
		 for(i=1;i<=n;i++)
		 		scanf("%d%d",&p[i].x,&p[i].y);
		if(n==2)
			printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,(double)sqrt((p[1].x-p[2].x)*(p[1].x-p[2].x)+(p[1].y-p[2].y)*(p[1].y-p[2].y)));
		else
		{
			int k;
			for(i=1;i<=n;i++)
				for(j=i+1;j<=n;j++)
					e[j][i]=e[i][j]=(double)sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
			for(i=1;i<=n;i++)
				dis[i]=e[1][i];	
			memset(book,0,sizeof(book));
			book[1]=1;
			for(i=1;i<n;i++)
			{
				min=inf;
				for(j=1;j<=n;j++)
				{
					if(book[j]==0&&dis[j]<min)
					{
						min=dis[j];
						u=j;
					}
				}
				book[u]=1;
				for(k=1;k<=n;k++)
					if(book[k]==0)
					{
						if(dis[k]>max(dis[u],e[u][k]))
							dis[k]=max(dis[u],e[u][k]);
					}
			}
			printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,dis[2]);
		}
	}
	return 0;	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值