HDU - 1016 Prime Ring Problem(dfs)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意描述:给出一个数字n且0<n<20,然后让你把这n个数字,组成一个环,且这个环的第一个数字一定是1,然后每两个相邻的数字之和必须为素数,如果有满足的就输出满足这样条件的n个数的顺序。

#include<stdio.h>
#include<math.h>
#include<string.h>

int b[25],book[25],n;

int prime(int a,int b)
{
	double m=a+b;
	int m1=a+b,k,i;
	k=(int)sqrt(m)+1;
	for(i=2;i<k;i++)
		if(m1%i==0)
			return 0;
	return 1;	
}
int count=0;

void dfs(int t)
{
	if(t-1==n)
	{
		if(prime(b[1],b[n])==1)
		{
			for(int i=1;i<n;i++)
				printf("%d ",b[i]);
			printf("%d\n",b[n]);
		}
		return ;
	}
	int j;
	for(j=2;j<=n;j++)
	{
		if(book[j]==0&&prime(b[t-1],j))
		{ 
			book[j]=1;
			b[t]=j;
			dfs(t+1);
			book[j]=0;
		}
	}
}
int main()
{
	int i,t=1,flag=1;
	while(~scanf("%d",&n))
	{
		
		memset(book,0,sizeof(book));
		printf("Case %d:\n",t++);
		book[1]=1;
		b[1]=1;
		dfs(2);
		printf("\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值