POJ1976A Mini Locomotive(dp 01背包)

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

  1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.
  2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.
  3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives.
Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.
Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240

题意描述:
给出t组样例每组样例有一个n和n个数这n个数代表n个车厢内的人数,然后有给出了一个m代表每个拖车能拉走的最大车厢数,然后车站只有三辆拖车,现在问你最多能拉走多少人。

解题方法:
i 表示拖车数,用 j 控制车厢数,然后再循环中dp[i][j]=max(dp[i][j-1],dp[i-1][j-m]+w[j]-w[j-m]);。dp[i][j-1],这个j-1表示跳过不要进行拖走的车厢。其中w[j]-w[j-m]这个是表示拖车连续拖走m节车厢,拖走的人数。

#include<stdio.h>
#include<string.h>

int max(int a,int b)
{
	if(a>b)
		return a;
	return b; 
}

int main(void)
{
	int dp[4][50005],w[50005];
	int t,n,m;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		w[0]=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&w[i]);
			w[i]+=w[i-1];
		 } 
		 scanf("%d",&m);
		 for(i=1;i<=3;i++)
		 	for(j=m;j<=n;j++)
				dp[i][j]=max(dp[i][j-1],dp[i-1][j-m]+w[j]-w[j-m]);
		 		
		printf("%d\n",dp[3][n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值