数据结构实验之查找一:二叉排序树

Problem Description
对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input
输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output
对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Example Input
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0Example Output
Yes
No
NoHint
  


#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
using namespace std;
typedef struct node{
	int data;
	struct node *lchild,*rchild;
}Tree;
int len,len1;
Tree *creat(Tree *root,int x){ //创建树 
	if(root==NULL){
		root = new Tree();
		root->data = x;
		root->lchild = root->rchild =NULL;
	}
	else{
		if(x<root->data)
		root->lchild = creat(root->lchild,x);
		else
		root->rchild = creat(root->rchild,x);
	}
	return root;
}
int judge(Tree *root,Tree *root1){//判断两棵树是否为同一个二叉排序树 
	if(root==NULL&&root1==NULL)
	return 1;
	else if(root!=NULL&&root1!=NULL){
		if(root->data!=root1->data)
		return 0;
		else if(judge(root->lchild,root1->lchild)&&judge(root->rchild,root1->rchild))
		return 1;
		else 
		return 0;
	}
	else
	return 0;
}
int main(){
	int n,m,i;
	int first[20],second[20];
	while(scanf("%d",&n)!=EOF,n){
		scanf("%d",&m);
		for(i=1;i<=n;i++)
		cin>>first[i];
		Tree *root = new Tree();
		root->data = first[1];
		root->lchild = root->rchild=NULL;
		for(i=2;i<=n;i++){
			root = creat(root,first[i]);
		}
		while(m--){
			for(i=1;i<=n;i++)
				cin>>second[i];
				Tree *root1 = new Tree();
				root1->data = second[1];
				root1->lchild=root1->rchild=NULL;
				for(i=2;i<=n;i++){
					root1=creat(root1,second[i]);
				}
				int key = judge(root,root1);
				if(key==1)
				cout<<"Yes"<<endl;
				else
				cout<<"No"<<endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值