PAT真题练习(甲级)1064 Complete Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
1 2 3 4 5 6 7 8 9 0
Sample Output 1:
6 3 8 1 5 7 9 0 2 4
一点想法
这道题主要是对完全二叉搜索树性质的考察
首先,我们要知道,完全二叉搜索树的中序遍历结果,为所有数字从小到大的排列。
其次,我们常用一个数组来表示完全二叉搜索树,并满足对于root节点 root * 2节点为他的左子,root * 2 + 1为他的右子
因此,本题中,我们读入数据后,对其进行排序,获得该树中序遍历的结果。之后对树进行中序遍历,并依照顺序赋值(类比于中序遍历输出结果,这里只是把输出结果改成赋值)。
AC代码
#include<iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <numeric>
using namespace std;
vector<int> tree;
vector<int> numbers;
int id = 0;
int N;
// 对树进行中序遍历,即可按顺序赋值
void inorder(int root) {
if (root > N) return;
inorder(root * 2);
tree[root] = numbers[id++];
inorder(root * 2 + 1);
}
int main() {
cin >> N;
numbers.resize(N);
tree.resize(N + 1);
for (auto i = 0; i < N;i++) {
cin >> numbers[i];
}
// 排序获得中序遍历的结果
sort(numbers.begin(), numbers.end());
inorder(1);
for (auto i = 1;i < N;i++) {
cout << tree[i] << " ";
}
cout << tree[N];
}