PAT真题练习(甲级)1049 Counting Ones (30 分)
原题网址:https://pintia.cn/problem-sets/994805342720868352/problems/994805430595731456
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (≤230).
Output Specification:
For each test case, print the number of 1’s in one line.
Sample Input :
12
Sample Output :
5
思路 :
这道题其实主要不是考验的代码能力,而是数学思维,暴力搜索显然是会超时的。
下面和大家分享我的理解思路:
首先,我们要将问题转化为求每个位上出现1的次数,然后我们逐步去分析。
假设N = 12,则对于个位数来说,出现1 的次数为2,分别是1、11;对于十位数来说,出现1的次数为3,分别是10、11、12。
这里我们要运用左右数分割的思想,对于某一位数来说,相对于左侧,他每隔10次会出现一次1,就好比11、21、31或者221、231……,因此我们可以感受到,他的出现次数应该为左数的大小,该位每次为1时,由于右侧数字的变化,这样的情况会重复出现多次,比如12中,十位数为1时,会出现10、11、12,也就是说出现的次数与右侧数字的个数有关。
总体来说,给定一个数N,统计从1到N的所有数字中1出现的次数
当前数字为now,对应now所处位数为a
now = 0:出现1的个数 = 左边数 * a
now = 1:出现1的个数 = 左边数 * a + 右边数 + 1
now > 1:出现1的个数 = (左边数 + 1) * a
AC代码
#include <stdio.h>
#include <iostream>
#include <math.h>
#include<string>
using namespace std;
int main() {
string num;
cin >> num;
int count = 0;
int now, left, right;
for (auto i = 0; i < num.length();i++) {
now = stoi(num.substr(i, 1));
if (i > 0) left = stoi(num.substr(0, i));
else left = 0;
int pos = num.length() - i - 1;
if (pos > 0) right = stoi(num.substr(i + 1, pos));
else right = 0;
if (now == 0) {
count += left * pow(10, pos);
}
else if (now == 1) {
count += left * pow(10, pos) + right + 1;
}
else {
count += (left + 1) * pow(10, pos);
}
}
cout << count;
}