PAT 1049 Counting Ones (30 分)

1049 Counting Ones (30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.


Input Specification:
Each input file contains one test case which gives the positive N (≤ 2 30 2^{30} 230).


Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:

12

Sample Output:

5




解析

#include<cstdio>
using namespace std;
int main()
{
	int N, result = 0, left, now, right, product = 1;;
	scanf("%d", &N);
	while (N/product != 0) {
		left = N / (product*10);
		now = N / product % 10;
		right = N % product;
		if (now == 0)	result += left*product; 
		else if (now == 1) result += left * product + right+1;
		else  result += (left + 1)*product;
		product *= 10;
	}
	printf("%d", result);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值