Starship Troopers HDU - 1011 树形dp

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible. 

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before. 

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer. 

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern. 

The last test case is followed by two -1's. 

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms. 

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

Sample Output

50
7

wa了好多次有必要写一篇博客,这题有一处需要注意:你最终策略选择路线中的叶子节点(注意是你策略路线形成树中的叶子节点)至少要留一个士兵,因此dfs里面dp时二层循环不能从0开始,必须从1开始。但是如果m等于0且为dfs到根节点时,要直接return ,因为dp二层循环从1开始只是限制了上对下的选择,上本身的并没有限制。

 

#include <cstdio>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int max_n=1e2+10;
typedef long long ll;
ll dp[max_n][max_n];
ll wei[max_n];
ll val[max_n];
int h[max_n];
int num;
struct Edge
{
	int u,v;
	int next;
}e[max_n<<1];
void add_edge(int u,int v)
{
	e[num].u=u;
	e[num].v=v;
	e[num].next=h[u];
	h[u]=num++;
}
void dfs(int u,int fa,int m)
{
	if(m*20<wei[u]||!m) return;
	int y=(wei[u]+19)/20;
	for(int i=y;i<=m;i++) dp[u][i]=val[u];
	for(int i=h[u];~i;i=e[i].next)
	{
		int v=e[i].v;
		if(v==fa) continue;
		dfs(v,u,m-y);
		for(int j=m;j>=y;j--)
			for(int k=1;k<=min(m-y,j-y);k++)
				dp[u][j]=max(dp[u][j],dp[u][j-k]+dp[v][k]);
	}
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==-1&&m==-1) break;
		num=0; for(int i=0;i<=n;i++) h[i]=-1;
		for(int i=1;i<=n;i++) for(int j=0;j<=m;j++) dp[i][j]=0;
		for(int i=1;i<=n;i++) scanf("%lld%lld",&wei[i],&val[i]);
		for(int i=1;i<n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			add_edge(u,v);
			add_edge(v,u);
		}
		dfs(1,0,m);
		printf("%lld\n",dp[1][m]);
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值