hdu-1011-Starship Troopers-树状dp-java

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7
 

解题思路:

               ε=(´ο`*)))唉 英语不好是硬伤啊!!! 最后才搞清楚这是无向图无向图无向图 重要的事情说三遍!!!!
               思路就是dfs+dp 这题很好理解 从第一个房间开始攻打 dp【房间号】【此时有多少个士兵】
               房间与房间相连 也就是你所在房间的最优值是其子树最优值的累加和

               那么动态转移方程就出来了       dp【i】【j】 = max{dp【i】【j】,dp【i】【j-k】+dp【子树】【k】}

               剩下的需要注意dfs 就跟递归似的 你想求此时的最优值就得求子树的最优值 求子树的最优值就得求子树的子树的最优值

               然后在从子树向根进行dp更新 找出最优值就可以了



import java.util.ArrayList;
import java.util.Scanner;


public class Main {


private static int m;
private static int n;
private static Scanner scanner;
private static int[][] dp;
private static ArrayList<Integer>[] graph;
private static int[][] arr;


public static void main(String[] args) {
// TODO Auto-generated method stub
        scanner = new Scanner(System.in);
        while (true) {
n = scanner.nextInt();
m = scanner.nextInt();
if(n==-1&&m==-1)break;
   createGraph();
   if(m==0) {
    System.out.println(0);
   }else {
   dp = new int [n+1][m+1];
   dfs(1,0);
   //从根节点开始搜
   //最后直接输出根节点就可以了
   //根节点此时是每层最优值的累加和
   System.out.println(dp[1][m]);
}
        }
}


private static void dfs(int r,int p) {//r号房间
   //先进行初始化 
   int a1 = (arr[r][0]+19)/20;//a1是干掉r号房间需要几个士
   for (int i = a1; i <=m; i++) {
dp[r][i] = arr[r][1];
}
            for (int i = 0; i < graph[r].size(); i++) {
int h = graph[r].get(i);//获取子节点
if (h!=p) {
dfs(h,r);//求出子节点的最优值
for (int j = m; j >=a1; j--) {
for (int j2 = 1; j2 <= j-a1; j2++) {
dp[r][j] = Math.max(dp[r][j], dp[h][j2]+dp[r][j-j2]);
//核心方程 攻打r号房间有j个士兵时的最优值
//是 子节点由父节点给了多少个兵的最优值 加上攻打r号房间有j减去分出去兵的个数的最优值
}
}
}

}
            
}


private static void createGraph() {
   arr = new int [n+1][2];
   graph = new ArrayList [n+1]; 
   for (int i = 1; i <=n; i++) {
arr[i][0] = scanner.nextInt();
arr[i][1] = scanner.nextInt();
}
   for (int i = 0; i < graph.length; i++) {
graph[i] = new ArrayList<Integer>(); 
}
   for (int i = 1; i < n; i++) {
int a = scanner.nextInt();
int b = scanner.nextInt();
graph[a].add(b);
graph[b].add(a);
}
}


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值