hdu 5492 Find a path 动态规划

Find a path

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 925    Accepted Submission(s): 405


Problem Description
Frog fell into a maze. This maze is a rectangle containing  N  rows and  M  columns. Each grid in this maze contains a number, which is called the magic value. Frog now stays at grid (1, 1), and he wants to go to grid (N, M). For each step, he can go to either the grid right to his current location or the grid below his location. Formally, he can move from grid (x, y) to (x + 1, y) or (x, y +1), if the grid he wants to go exists.
Frog is a perfectionist, so he'd like to find the most beautiful path. He defines the beauty of a path in the following way. Let’s denote the magic values along a path from (1, 1) to (n, m) as  A1,A2,AN+M1 , and  Aavg  is the average value of all  Ai . The beauty of the path is  (N+M1)  multiplies the variance of the values: (N+M1)N+M1i=1(AiAavg)2
In Frog's opinion, the smaller, the better. A path with smaller beauty value is more beautiful. He asks you to help him find the most beautiful path. 
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T50 ).
Each test case starts with a line containing two integers  N  and  M  ( 1N,M30 ). Each of the next  N  lines contains  M  non-negative integers, indicating the magic values. The magic values are no greater than 30.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the minimum beauty value.
 

Sample Input
  
  
1 2 2 1 2 3 4
 

Sample Output
  
  
Case #1: 14
 

展开方程得到:sum(Ai*Ai)*(n+m-1) - sum(Ai)*sum(Ai)

定义dp[i][j][k]表示i,j位置时,sum(Ai) 为k的路径中sum(Ai*Ai)的最小值。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int mp[40][40];
int dp[31][31][1877];

int main(){
    int t,n,tt=1,m;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= n; i++)
            for(int j = 1;j <= m; j++)
                scanf("%d",&mp[i][j]);
        memset(dp,0x3f,sizeof(dp));
        dp[1][0][0] = 0;
        for(int i = 1;i <= n; i++){
            for(int j = 1;j <= m; j++){
                int z = mp[i][j];
                int x = (n+m-1)*z*z;
                int y = (i+j-1)*30;
                for(int k = 0;k <= y; k++)
                    dp[i][j][k+z] = min(dp[i][j][k+z],dp[i][j-1][k]+x);
                for(int k = 0;k <= y; k++)
                    dp[i][j][k+z] = min(dp[i][j][k+z],dp[i-1][j][k]+x);
            }

        }
        int ans = dp[0][0][0];
        for(int i = 0 ;i <= 1800; i++){
            ans = min(ans,dp[n][m][i]-i*i);
        }
        printf("Case #%d: %d\n",tt++,ans);
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值