hdoj5492Find a path【dp】

Find a path

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1173    Accepted Submission(s): 511


Problem Description
Frog fell into a maze. This maze is a rectangle containing  N  rows and  M  columns. Each grid in this maze contains a number, which is called the magic value. Frog now stays at grid (1, 1), and he wants to go to grid (N, M). For each step, he can go to either the grid right to his current location or the grid below his location. Formally, he can move from grid (x, y) to (x + 1, y) or (x, y +1), if the grid he wants to go exists.
Frog is a perfectionist, so he'd like to find the most beautiful path. He defines the beauty of a path in the following way. Let’s denote the magic values along a path from (1, 1) to (n, m) as  A1,A2,AN+M1 , and  Aavg  is the average value of all  Ai . The beauty of the path is  (N+M1)  multiplies the variance of the values: (N+M1)N+M1i=1(AiAavg)2
In Frog's opinion, the smaller, the better. A path with smaller beauty value is more beautiful. He asks you to help him find the most beautiful path. 
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T50 ).
Each test case starts with a line containing two integers  N  and  M  ( 1N,M30 ). Each of the next  N  lines contains  M  non-negative integers, indicating the magic values. The magic values are no greater than 30.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the minimum beauty value.
 

Sample Input
  
  
1 2 2 1 2 3 4
 

Sample Output
  
  
Case #1: 14
 

Source
 

题意:给一个矩形迷宫每个格子上有一个值Ai求从左上角走到右下角使得 (N+M1)
N+M1i=1(AiAavg)2 值最小观察此式和方差的计算公式类似因此可利用
方差的计算公式简化此式为(N+M1)A2i(Ai)2
/*
dp[i][j][k]在第i行第j个格子处所经过的路径和为k时格子的平方和的最小值 
*/
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
int map[35][35];
int dp[35][35][2010];
int main()
{
	int t,n,m,i,j,test=1,k;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i){
			for(j=1;j<=m;++j){
				scanf("%d",&map[i][j]);
			}
		}
		memset(dp,0x3f,sizeof(dp));
		dp[1][0][0]=dp[0][1][0]=0;
		for(i=1;i<=n;++i){
			for(j=1;j<=m;++j){
				for(k=0;k<=1800;++k){
					dp[i][j][k+map[i][j]]=min(dp[i][j][k+map[i][j]],min(dp[i-1][j][k],dp[i][j-1][k])+map[i][j]*map[i][j]);
				}
			}
		}
		int ans=inf;
		for(k=0;k<=1800;++k){
			if(dp[n][m][k]!=inf)
				ans=min(ans,dp[n][m][k]*(n+m-1)-k*k);
		}
		printf("Case #%d: %d\n",test++,ans);
	}
	return 0;
}


i=1N+M1i=1)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值