POJ 2785(4 Value whose sum is 0)(双哈希)

POJ 2785(4 Value whose sum is 0)(双哈希)

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
 Sample Output
5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

算法

这道题目网上有很多解法使用哈希+排序+二分(也不知道都排序了为什么还叫哈希)。

我的算法是:

将前两个元素的所有可能的和储存在一个哈希表内,然后在生成后两个元素所有可能的和的同时,在前一个哈希表中找它的相反数。

但是在实际设计中,线性探查(Linear Probing)会导致TLE,测试了几次之后,使用双哈希(double hashing)并采用合适的哈希函数可以AC。

在CLRS(Introduction to Algorithms)中,作者介绍线性探查和平方探查的方法是heuristic(启发式的),亦即并非正确的,只是还行。所以哈希题目多设计几次哈希函数也是比较正常的事吧。

AC Code
#include<cstdio>

const int MaxSize = 4000;
const int Mod = MaxSize * (MaxSize + 100) + 1;

using namespace std;

struct element
{
    int val;
    int num;
};

// double hashing
int Hash(element T[], int val);
int Hash2(int val)
{
    // Select a good hash function
    return val % MaxSize * 100 + 1;
}

element HashTable[Mod + 2];
int Data[4][MaxSize + 2];

int main()
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int size;
    scanf("%d", &size);
    for (int i = 0; i < size; ++i) {
        for (int j = 0; j < 4; ++j) {
            scanf("%d", &Data[j][i]);
        }
    }

    for (int i = 0; i < size; ++i) {
        for (int j = 0; j < size; ++j) {
            int t = Hash(HashTable, Data[0][i] + Data[1][j]);
            ++(HashTable[t].num);
            HashTable[t].val = Data[0][i] + Data[1][j];
        }
    }

    int ans = 0;
    for (int i = 0; i < size; ++i) {
        for (int j = 0; j < size; ++j) {
            int t = Hash(HashTable, -(Data[2][i] + Data[3][j]));
            ans += HashTable[t].num;
        }
    }

    printf("%d\n", ans);

    return 0;
}

int Hash(element T[], int val)
{
    int absolute = (val > 0) ? (val) : (-val);
    int t = absolute % Mod;
    int k = Hash2(absolute);
    while (T[t].num != 0 && T[t].val != val) {
        t = (t + k) % Mod;
    }
    return t;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值