poj 2785(折半枚举 双向搜索)

4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 32325 Accepted: 9932
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:有4个数列   每列找一个数,得到和为0的序列,有几种不同的方案

对1,2列的数求一个和,3,4列的数求一个和,然后进行二分查找

 

分析:如果一个一个枚举那么总共有n^4种情况  但是要全部判断一遍是不行的。不过将他们对半分成AB和CD在考虑,就可以快速地解决问题了。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=4005;
int a[N],b[N],c[N],d[N],e[N*N];
int main()
{
	int n;
	while(scanf("%d",&n)==1){
		for(int i=0;i<n;i++){
			scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				e[i*n+j]=c[i]+d[j];
			}
		}
		sort(e,e+n*n);
		int cnt=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				int cd=-(a[i]+b[j]);
				cnt+=upper_bound(e,e+n*n,cd)-lower_bound(e,e+n*n,cd);
			}
		} 
		printf("%d\n",cnt);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值