PC 110102 Minesweeper 扫雷//水题

Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can't remember. The goal of the game is to find where all the mines are located within a M x N field.

The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The x 4 field on the left contains two mines, each represented by a ``*'' character. If we represent the same field by the hint numbers described above, we end up with the field on the right:

Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < nm《=100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field.

Safe squares are denoted by ``.'' and mine squares by ``*,'' both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.

Output

For each field, print the message Field #xon a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.'' characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100



这道题是水题,但是还是WA了两次。
额,第一次WA是因为把宽和高的范围看错了,看成8*8了
第二次因为漏看了一个条件导致的(已经再题中标红并且放大了)





#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
char g[101][101];
int r[101][101];
int dir[8][2]={{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}};

int main()
{
	freopen("c:\\in.txt","r",stdin);
	int w, h, i, j,ii, jj, x ,y, cases = 0;
	while (cin>>h>>w)
	{
		if (h==0 || w==0) break;
		if (cases) printf("\n");
		cases ++;
		memset(g, 0, sizeof(g));
		memset(r, 0, sizeof(r));
		for (i=0; i<h; i++)
		{
			for (j=0; j<w; j++)
			{
				cin>>g[i][j];
			}
		}
		for (i=0; i<h; i++)
		{
			for (j=0; j<w; j++)
			{
				if (g[i][j]=='*') r[i][j]=-1;
				else
				{
					for (ii=0; ii<8; ii++)
					{
						y = i+dir[ii][0];
						x = j+dir[ii][1];
						if (x>=0 && x<w && y>=0 && y<h && g[y][x]=='*')
						{
							++r[i][j];
						}
					}
				}
			}
		}
		printf("Field #%d:\n",cases);
		for (i=0; i<h; i++)
		{
			for (j=0; j<w; j++)
			{
				if (r[i][j]==-1) cout<<"*";
				else printf("%d",r[i][j]);
			}
			printf("\n");
		}
		
	}	
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值