Zjnu Stadium(并查集)

Zjnu Stadium

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6 Accepted Submission(s) : 6
Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.


Output
For every case:
Output R, represents the number of incorrect request.

Sample Input
  
  
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100

Sample Output
  
  
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)

Source
2009 Multi-University Training Contest 14 - Host by ZJNU

题意:

有一个体育馆,座位呈环状,共有300列,按顺时针方向编号为1~300,假设行数无穷大。有N个人(编号为1~N)来到这个体育馆看一场赛事,主办方提出了M个要求,要求的格式是"A B X",表示的是,假设A坐在编号为i的列,则B必须坐在编号为(i+x)%300的列上,模300是因为座位呈环状。。这些要求里有一些是错误的,只有和前面的要求产生冲突时才算错误,其它都是正确的。程序要输出错误的要求个数。

题解:并查集,由于题目中有说明只有当后面输入的要求与前面不符时才为错误,则用并查集每次寻找根节点,定义数组把每次所经过

            的节点的权值(即为x,a,b两节点的的距离)加权,则每次数据输入时加权数组对应的权值即为该点相对于第一次输入点时的距离(题目要求按顺时针

           方向),每次输入的a ,b点若父节点一样则判定已知两点的距离取模与输入x是否相等(有可能为负值即b在a前,则权值加300),若不等则f[b]=a,权值数组

          x+[a]-[b]


#include<cstdio>
#include<cstring>
using namespace std;
const int N=50010;
const int md=300;
int set[N],sum[N];
int find(int x)
{
    if(set[x]==x)return x;
    int t=find(set[x]);
    sum[x]+=sum[set[x]];
    return set[x]=t;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)set[i]=i;
        int cnt=0;
        while(m--)
        {
            int a,b,x;
            scanf("%d%d%d",&a,&b,&x);
            int fa=find(a),fb=find(b);
            if(fa==fb)
            {
                int t=(sum[b]-sum[a])%md;
                if(t<0) t+=md;
                if(t!=x) cnt++;
            }
            else
            {
                set[fb]=fa;
                sum[fb]=x+sum[a]-sum[b];
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

           


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值