A Famous City(单调栈)

A Famous City

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 115 Accepted Submission(s): 62


Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.

Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000.

Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.

Sample Input
3
1 2 3
3
1 2 1
Sample Output
Case 1: 3
Case 2: 2
Hint
The possible configurations of the samples are illustrated below:

Source


单调栈(栈内元素满足单调性)
分析: 从左向右分析每个piece。 当前piece 如果和左边相邻的高度相等,那么肯定是同一个建筑的。 如果当前piece比左边相邻的大,那么两者肯定属于不同的建筑。 如果当前piece高度小于左邻的piece的高度,那么当前的piece可能和更左边的piece属于同一个建筑,于是需要向左找到,直到找到比当前piece矮的或者相等的piece,并且向左找的过程中经过的piece肯定就不可能再和当前piece的右边的piece属于同一建筑了。 最后注意不要忘了长度为0的piece的影响



#include <iostream> 
#include <cstdio> 
#include <algorithm> 
#include <cstring> 
using namespace std; 
const int maxn= 100011; 
int stk[maxn], top;     // stk[]栈, top表示栈中的元素个数 
int main(){
         int nca=0, n;     
         while(~scanf("%d", &n))
         {         
             int cnt= 0;         
             top= 0;         
             for(int i=0;i<n;i++)
             {             
                 int x;             
                 cin>> x;             
                 while( top>0 && stk[top-1]>x)
                 {                 
                     top--;                 
                     cnt++;             
                 }             
                 if (x!=0 && (top==0|| x> stk[top-1]))
                 {                 
                     stk[top++]= x;             
                 }           
            }         
            printf("Case %d: %d\n", ++nca, cnt+top);
    }   
            
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值