People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input:
15 43 71
Sample Output:
#123456
solution:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
const int maxn=1e5+5;
string turn(string a)
{
int tmp=2;
int cnt=stoi(a);
string ans;
vector<int>t;
while(cnt)
{
t.push_back(cnt%13);
cnt/=13;
}
reverse(t.begin(),t.end());
for(auto i:t)
{
if(i>=10)ans+=i-10+'A';
else ans+=to_string(i);
}
while(ans.size()<tmp)ans='0'+ans;
return ans;
}
int main()
{
string a,b,c;
cin>>a>>b>>c;
cout<<"#"<<turn(a)<<turn(b)<<turn(c)<<endl;
}