Pyecharts安装教程

Pyecharts 1.0以后的版本只能支持Python3.6及以上版本,因此,在安装Pyecharts之前首先明确要使用的python版本,对于Python3.6及以上版本可以直接在命令行窗口中

pip install pyecharts

或者

pip install -i https://pypi.tuna.tsinghua.edu.cn/simple

进行安装,对于低版本的python,可以通过指定版本进行安装,例如:

pip install -i https://pypi.tuna.tsinghua.edu.cn/simple pyecharts==0.5.11

 

安装完成之后可以通过案例进行测试;例如:

#导入柱状图-Bar
from pyecharts import Bar
#设置行名
columns = ["Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov", "Dec"]
#设置数据
data1 = [2.0, 4.9, 7.0, 23.2, 25.6, 76.7, 135.6, 162.2, 32.6, 20.0, 6.4, 3.3]
data2 = [2.6, 5.9, 9.0, 26.4, 28.7, 70.7, 175.6, 182.2, 48.7, 18.8, 6.0, 2.3]
#设置柱状图的主标题与副标题
bar = Bar("柱状图", "一年的降水量与蒸发量")
#添加柱状图的数据及配置项
bar.add("降水量", columns, data1, mark_line=["average"], mark_point=["max", "min"])
bar.add("蒸发量", columns, data2, mark_line=["average"], mark_point=["max", "min"])
#生成本地文件(默认为.html文件)
bar.render()

最后在python当前工作目录下生成一个render.html文件

 

可能遇到问题及解决办法:

1.python和pyecharts版本不匹配问题

在运行上述案例中,可能报以下错误:

   (/导入柱状图-Bar)
     ^
SyntaxError: invalid syntax

解决方法:建议降低pyecharts版本

2.pyecharts_snapshot报错

ERROR:lml.utils:failed to import pyecharts_snapshot

解决方法:重装pyecharts_snapshot,下载地址 https://pypi.org/project/pyecharts-snapshot/,注意事项:pyecharts_snapshot不同版本支持的python版本不同,安装前请仔细阅读网站说明,可以直接安装,

pip install pyecharts-snapshot

也可以先下载相应的版本之后,再安装:

pip install pyecharts_snapshot-0.1.8-py2.py3-none-any.whl

 

 

 

发布了8 篇原创文章 · 获赞 0 · 访问量 659
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览