【HDU 1394】Minimum Inversion Number

【题目】

传送门

Problem Description

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16


【分析】

题目大意:给出一个 1 1 1 ~ n n n 的排列,可以不断地把第一个数放到最后,求所有方案中逆序对的最小值

先求出原始序列中的逆序对个数,然后考虑把第一个数放到最后的贡献

由于这是一个排列,假设第一个数为 x x x,那么小于 x x x 的数有 x − 1 x-1 x1 个,大于它的有 n − x n-x nx

所以每次更新就直接 s u m = s u m − ( x − 1 ) + ( n − x ) sum=sum-(x-1)+(n-x) sum=sum(x1)+(nx),记一下最小值即可

P s Ps Ps:原题中给出的是 0 0 0 ~ n − 1 n-1 n1 的排列,我是直接加 1 1 1 变成 1 1 1 ~ n n n 的排列

【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 5005
#define lowbit(x) x&-x
#define inf (1ll<<31ll)-1
using namespace std;
int n,a[N],tree[N];
void add(int i,int x)
{
	while(i<=n)
	{
		tree[i]+=x;
		i+=lowbit(i);
	}
}
int query(int i)
{
	int ans=0;
	while(i>=1)
	{
		ans+=tree[i];
		i-=lowbit(i);
	}
	return ans;
}
int main()
{
	int i;
	while(~scanf("%d",&n))
	{
		int sum=0;
		memset(tree,0,sizeof(tree));
		for(i=1;i<=n;++i)
		{
			scanf("%d",&a[i]);
			a[i]++,add(a[i],1);
			sum+=i-query(a[i]);
		}
		int Min=sum;
		for(i=1;i<n;++i)
		{
			sum=sum-(a[i]-1)+(n-a[i]);
			Min=min(Min,sum);
		}
		printf("%d\n",Min);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值