【HDU 1079】Calendar Game

【题目】

传送门

Description

Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

Output

Print exactly one line for each test case. The line should contain the answer “YES” or “NO” to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of “YES” or “NO”.

Sample Input

3
2001 11 3
2001 11 2
2001 10 3

Sample Output

YES
NO
NO


【分析】

题目大意:给定一个 2001 / 11 / 04 2001/11/04 2001/11/04 前的合法日期,每次可以变成下一天,或者变成下一个月的同一天(下个月必须有这一天),两个人轮流变化,问先手是否能必定先到 2001 / 11 / 04 2001/11/04 2001/11/04

这道题其实挺妙的。

y y y 表示年,用 m m m 表示月,用 d d d 表示天。

考虑到每变化一次, m + d m+d m+d 的奇偶性都会变(除了 9 9 9 30 30 30 日和 11 11 11 30 30 30 日)。

由于最终我们需要的 11 + 4 = 15 11+4=15 11+4=15 是一个奇数,因此只有当原来的 m + d m+d m+d 就是奇数或者上面两个特殊日期才能先手必胜,否则就不能。


【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int T,y,m,d;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&y,&m,&d);
		puts((!((m+d)&1)||m==9&&d==30||m==11&&d==30)?"YES":"NO");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值